[lammps-users] Installation Problem

Dear all,
I am trying to install LAMMPS in liux (RedHat, compiler icc, with FFTW-2.1.5). I am getting the following error. Could someone help me in resolving the issue. Herewith i am attaching the Makefile that i created for LAMMPS.

Error:
special.o thermo.o timer.o universe.o update.o variable.o velocity.o verlet.o write_restart.o -lmpich -lpthread -lfftw -lstdc++ -lfftw -lmpich -lpthread -o ../lmp_lin
ld: cannot find -lmpich
gmake[1]: *** [../lmp_lin] Error 1
gmake[1]: Leaving directory `/home/accelrys/other_downloads/lammps/lammps-18Jan11/src/Obj_lin'
gmake: *** [lin] Error 2

MAKEFILE
# lin = RedHat Linux box, Intel icc, Intel ifort, MPICH2, FFTW

SHELL = /bin/sh

# ---------------------------------------------------------------------
# compiler/linker settings
# specify flags and libraries needed for your compiler

CC = icc
CCFLAGS = -O -I/usr/local/include -DFFT_FFTW -DLAMMPS_GZIP -DMPICH_IGNOR_CXX_SEEK
DEPFLAGS = -M
LINK = /opt/intel/bin/icc
LINKFLAGS = -O -L/usr/local/lib
LIB = -lstdc++ -lfftw -lmpich -lpthread
ARCHIVE = ar
ARFLAGS = -rc
SIZE = size

Thanking you

Sincerely
Naresh

Dear all,
I am trying to install LAMMPS in liux (RedHat, compiler icc, with FFTW-2.1.5). I am getting the following error. Could someone help me in resolving the issue. Herewith i am attaching the Makefile that i created for LAMMPS.

the error indicates that your linker cannot find a library file.
that means, that either you are missing this file or your
makefile has the wrong settings. this is very machine and
installation specific and there is no easy way to solve that
remotely. you need adapt the makefile in a way that is needed
for compiling an MPI parallel program successfully on your machine,
so you have to find out how to do that first.

axel.