[lammps-users] Is there a limitation for total number of atoms


I created 1600 molecules each with 10 beads using chain tool. I tried to perform a test run and got segmentation error. I tried to find the maximum number of atoms one can simulate on a single workstation, but was not able to locate it.

Another thing suspicious is the data file generated by chain tool. When the number of atoms is more than 10000, there will be no space between atom number and molecule number as show below,


1 1 1 3.9134 8.4361 10.1750 0 0 0
2 1 1 3.1131 8.3007 9.6439 0 0 0

137891379 1 -3.6824 8.3512 -6.2611 0 0 0

the last item means the atom number is 13789, and molecule number is 1379.

Could anyone let me know what might cause the segmentation error. Thank you so much for your help. I seems to me that no space between atom number and molecule number is the reason. If so, is there a good way to solve it, or one has to manually insert spaces.



I agree with your conclusions. You’ll need to modify the chain tool to put a space there, or do it by hand.

If you change line 23 of chain.f from:

903 format(i6,i4,i4,3f10.4,3i4)


903 format(i10,i6,i6,3f10.4,3i4)

then recompile and rerun the chain code, I think it will work.