[lammps-users] Lammps and opensuse 11.2

Hi , i was trying to make a new installation of lammps in opensuse 11.2 with gpu. I haven’t installed lammps ever before in an opensuse linux.
I did the same things ; installed mpich2 , fftw2.1 in usr/local/mpichmpich2-1.2.1 and usr/local/fftw-2.1.5 respectively. I then took the file makefile.g++ ,because there is no more an opensuse make file and i wrote something like this:

SHELL = /bin/sh
MPI_INC =/usr/local/mpich2-1.2.1/include
#MPI_PATH = /usr/local/mpich2-1.2.1/bin
MPI_LIB =/usr/local/mpich2-1.2.1/lib

FFTW_INC=/usr/local/fftw-2.1.5/include
FFTW_LIB=/usr/local/fftw-2.1.5/lib

CC = g++
CCFLAGS = -g -O -I$(MPI_INC) -I$(FFTW_INC)
-DFFT_FFTW -DGZIP

-DMPICH_IGNORE_CXX_SEEK

DEPFLAGS = -M
LINK = g++
LINKFLAGS = -g -O -L$(MPI_LIB) -L$(FFTW_LIB)
USRLIB = -lmpi -lfftw
#-lpthread -lmpi_cxx
SYSLIB =
ARCHIVE = ar
ARFLAGS = -rc
SIZE = size

---------------------------------------------------------------------

LAMMPS-specific settings

specify settings for LAMMPS features you will use

LAMMPS ifdef options, see doc/Section_start.html

MPI library, can be src/STUBS dummy lib

INC = path for mpi.h, MPI compiler settings

PATH = path for MPI library

LIB = name of MPI library

FFT library, can be -DFFT_NONE if not using PPPM from KSPACE package

INC = -DFFT_FFTW, -DFFT_INTEL, -DFFT_NONE, etc, FFT compiler settings

PATH = path for FFT library

LIB = name of FFT library

System-specific settings

#FFT_PATH =

additional system libraries needed by LAMMPS package libraries

these settings are IGNORED if the corresponding LAMMPS package

(e.g. gpu, meam) is NOT included in the LAMMPS build

SYSLIB = names of libraries

SYSPATH = paths of libraries

gpu_SYSLIB = -lcudart
meam_SYSLIB = -lifcore -lsvml -lompstub -limf
reax_SYSLIB = -lifcore -lsvml -lompstub -limf
user-atc_SYSLIB = -lblas -llapack

gpu_SYSPATH = -L/usr/local/cuda/lib64
meam_SYSPATH = -L/opt/intel/fce/10.0.023/lib
reax_SYSPATH = -L/opt/intel/fce/10.0.023/lib
user-atc_SYSPATH =

---------------------------------------------------------------------

build rules and dependencies

no need to edit this section

include Makefile.package

EXTRA_INC = (LMP_INC) (PKG_INC) (MPI_INC) (FFT_INC)
EXTRA_PATH = (PKG_PATH) (MPI_PATH) (FFT_PATH) (PKG_SYSPATH)
EXTRA_LIB = (PKG_LIB) (MPI_LIB) (FFT_LIB) (PKG_SYSLIB)

Link target

(EXE): (OBJ)
(LINK) (LINKFLAGS) (EXTRA_PATH) (OBJ) (EXTRA_LIB) (LIB) -o (EXE) (SIZE) $(EXE)

Library target

lib: (OBJ) (ARCHIVE) (ARFLAGS) (EXE) $(OBJ)

Compilation rules

.o:.cpp
(CC) (CCFLAGS) (EXTRA_INC) -c <

.d:.cpp
(CC) (CCFLAGS) (EXTRA_INC) (DEPFLAGS) < > @

Individual dependencies

DEPENDS = (OBJ:.o=.d) include (DEPENDS)

Did it work or do you have a question?

Steve

2010/4/28 Jim Jim <[email protected]...>:

No it didn’t.It says during the making a lot of:

g++: /usr/local/mpich2-1.2.1/include: linker input file unused because linking not done

and at the end

/usr/local/mpich2-1.2.1/lib: file not recognized: Is a directory

collect2: ld returned 1 exit status
make[1]: *** […/lmp_g++] Error 1
make[1]: Leaving directory `/home/dimitris/Desktop/lammps-26Apr10/src/Obj_g++’
make: *** [g++] Error 2

/usr/local/mpich2-1.2.1/lib: file not recognized: Is a directory

This error means you didn't specify the link path and MPI library
file correctly - you need to find where it is on your system and
make sure the -L and -l (small L) settings are correct on your box.

Then look at the link link echoed by the Makefile, and make sure
the settings appear as you think you specified them.

Steve

2010/4/28 Jim Jim <[email protected]...>: