[lammps-users] LAMMPS hangs

Hello all,

Am trying to run a 22,000 atom simulation containing water and TiO2. Lammps hangs/freezes at:
WARNING: Resetting reneighboring criteria during minimization
Ewald initialization …
G vector = 0.427791
vectors: actual 1d max = 70506 80 2086640
Setting up minimization …
Am using a
pair_style hybrid/overlay buck/coul/long 8.0 lj/cut/coul/long 8.0
its mpich2(intel mkl) compiled running on 128 cores (xeons) with 1 GB mem per core


I would run PPPM, not Ewald. It will be much faster. Without
more info, I have no idea why it would be hanging, as opposed to
just slow.


Hello all,

I tried running it on a single core and it seems that as much available memory is consumed and until the machine hangs, and so does the queing system on a cluster. I have attached the requisite input files. I think I am doing something seriously wrong.


in.step-1-wat (1.25 KB)

data.step-1-wat (1.88 MB)

You have lines like this in your input script:

pair_coeff 1 1 buck/coul/long 8.0 717647.4 0.154 121.0676
pair_coeff 2 2 buck/coul/long 8.0 271716.3 0.234 696.8883

Which are setting the cutoff to 700 Angstroms. Which will require
LAMMPS to work for a long time to compute the pairwise interactions.
Hence the "hang".

I think you want the last arg, not the first to be 8.0. But you don't
even need it since you specified it in the pair_style command.

See the doc page for pair buck/coul/long for syntax of the pair_coeff



yup, thanks again Steve, thats fixed it.