[lammps-users] mpirun segmentation fault while using reax/c


I am trying to learn running REAXFF simulations using LAMMPS and thus was trying simulate some test runs. There are a few errors I am running into.

Before describing the issue, let me acknowledge the fact that the primary error which the the subjectline of the mail, I do realize that the issue might not be related to LAMMPS but rather mpirun. Having searched over through google, I couldn’t find any answers to resolve the issue, thus writing the mail to the mailing list as my last resort. Accepting the fact that I do no have a thorough understanding of REAXFF, I had to start somewhere. Apologies if I haven’t been extra careful while running simulations and/or resolving the simulation errors.

I ran the ReaxFF simulations from the examples file and they worked well, thus I decided to graduate to a different system. The system I chose to run ReaxFF simulations is a 100mer polyethylene system with just 602 atoms, packed in a cubical box with dimensions equalling 500 angstroms.

I am running a polymer relaxation simulation wherein the code is asked to relax the polymer geometry and further shrink the box size in order to get realistic polymer density.

The error I get at the end of the run is -

[adrenaline:207274] *** Process received signal ***
[adrenaline:207274] Signal: Segmentation fault (11)
[adrenaline:207274] Signal code: Address not mapped (1)
[adrenaline:207274] Failing at address: 0x562d5d108ab4
[adrenaline:207274] [ 0] /lib/x86_64-linux-gnu/libpthread.so.0(+0x153c0)[0x7fcdf53993c0]
[adrenaline:207274] [ 1] /home/jignesh/Lammps/build/lmp(+0xc122c6)[0x562bd9d2d2c6]
[adrenaline:207274] [ 2] /home/jignesh/Lammps/build/lmp(+0xc12b2f)[0x562bd9d2db2f]
[adrenaline:207274] [ 3] /home/jignesh/Lammps/build/lmp(+0xc133bb)[0x562bd9d2e3bb]
[adrenaline:207274] [ 4] /home/jignesh/Lammps/build/lmp(+0xc09e7e)[0x562bd9d24e7e]
[adrenaline:207274] [ 5] /home/jignesh/Lammps/build/lmp(+0x3267d0)[0x562bd94417d0]
[adrenaline:207274] [ 6] /home/jignesh/Lammps/build/lmp(+0x2dee8e)[0x562bd93f9e8e]
[adrenaline:207274] [ 7] /home/jignesh/Lammps/build/lmp(+0x2281a3)[0x562bd93431a3]
[adrenaline:207274] [ 8] /home/jignesh/Lammps/build/lmp(+0x225a9a)[0x562bd9340a9a]
[adrenaline:207274] [ 9] /home/jignesh/Lammps/build/lmp(+0x2261e5)[0x562bd93411e5]
[adrenaline:207274] [10] /home/jignesh/Lammps/build/lmp(+0x21995d)[0x562bd933495d]
[adrenaline:207274] [11] /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf3)[0x7fcdf48f90b3]
[adrenaline:207274] [12] /home/jignesh/Lammps/build/lmp(+0x21ad0e)[0x562bd9335d0e]
[adrenaline:207274] *** End of error message ***

ffield.reax.lg (11.6 KB)

in.total_equi (2.67 KB)

lmp_control (1014 Bytes)

test602_charge.data (29.6 KB)

Have you visualized the trajectory? Does the system behave like it should?

ReaxFF is very sensitive to situations where the local environment changes substantially (due to its memory management design) which can happen when the parameters or timestep or thermostat settings are not suitable for the system at hand or the conditions at which the system is simulated.

If the trajectory is reasonable, then another option to try would be to use the KOKKOS variant of the ReaxFF pair style (can be run on the CPU just as well), which has a more robust memory management, that may help under conditions where the original implementation cannot cope. With that in mind, I would also recommend upgrading to the most recent LAMMPS release.

Dr. Axel Kohlmeyer
Thanks for your suggestions. Updating to the latest version of LAMMPS and using KOKKOS Package worked. Also had to tweak the timestep and thermostat parameters too. Thanks alot.

Jignesh D.