[lammps-users] (no subject)

Hi,

When I ‘make’ lammps inside the src folder with g++3, i get the following errors: Could you point out the reason?

fix_adapt.cpp: In member function »virtual void LAMMPS_NS::FixAdapt::pre_force(int)«:
fix_adapt.cpp:182: Fehler: invalid use of incomplete type »struct LAMMPS_NS::Update«
lammps.h:31: Fehler: forward declaration of »struct LAMMPS_NS::Update«
fix_adapt.cpp:186: Fehler: invalid use of incomplete type »struct LAMMPS_NS::Modify«
lammps.h:36: Fehler: forward declaration of »struct LAMMPS_NS::Modify«
fix_adapt.cpp:219: Fehler: invalid use of incomplete type »struct LAMMPS_NS::Modify«
lammps.h:36: Fehler: forward declaration of »struct LAMMPS_NS::Modify«
fix_adapt.cpp:219: Fehler: invalid use of incomplete type »struct LAMMPS_NS::Update«
lammps.h:31: Fehler: forward declaration of »struct LAMMPS_NS::Update«
make[1]: *** [fix_adapt.o] Fehler 1
make[1]: Verlasse Verzeichnis '/auto/ls1/swayamj/lammps/lammps-26Jun10/src/Obj_g++3’
make: *** [g++3] Fehler 2

Re-download the latest patch or full version - there was a glitch with
fix_adapt.c
that has been corrected.

Steve