[lammps-users] Pizza-7Nov05 problem

Hi all,

I have been using log.py in pizza-7Nov05 toolkit to obtain thermodynamic properties.
It has worked very well with log files made from previous version, lammps-3Jun05.

However, few days ago, I upgraded lammps simulator to current version, lammps-10Nov05 (with reported fixes) and found the following error messages after using log command with a log file made from current version, lammps-10Nov05.

l=log(“lammps.log”)
Traceback (most recent call last):
File “”, line 1, in ?
File “/home/oioioioi/MD_utilities/pizza-7Nov05/src/log.py”, line 83, in init
self.read_all()
File “/home/oioioioi/MD_utilities/pizza-7Nov05/src/log.py”, line 95, in read_all
self.read_header(self.flist[0])
File “/home/oioioioi/MD_utilities/pizza-7Nov05/src/log.py”, line 244, in read_header
keyword = re.search(pattern,fields[i]).group(1)
AttributeError: ‘NoneType’ object has no attribute ‘group’

The log command works well with a log file made from previous version, lammps-3Jun05.
Maybe it is from the different format or header of new log files, but I am not sure.

I tried to fix pizza script, but I failed. I am not good at python.
Could anybody help me how I can fix this problem?

Many thanks in advance,

Jihoon Kang

Department of Mechanical Engineering, Korea Advanced Institute of Science and Technology(KAIST)
373-1, Guseongdong, Yuseonggu, Daejeon, Korea
Tel: +82-42-869-3286, Fax: +82-42-869-3210
e-mail: [email protected]…59…