[lammps-users] Problem compiling LAMMPS with REAX on AIX

The setting you needed already exists, see below.


I want to print dump file not at regular interval but at random stepnumbers.
Can u suggest me what to do?

Hi Dhiraj,

I'm not sure what you mean by random stepnumbers. If you mean
irregular intervals, you could try breaking your run into
smaller segments and prefacing each segment with a different
frequency for your dumps using the dump_modify command with the
every keyword.

Joanne Budzien

Hi Dhiraj,

Not sure if disk space is an issue (i.e. how large your system is) but you could dump at a fairly high (regular) frequency and then post process to select randomly from among those dumps.


Thanks Steve for the help.

Please excuse me for my ignorance - but it wouldn’t have occurred to me how to use the -D_IBM option – it would have saved a lot of time actually. In my honest opinion you may consider putting this up on the ‘Making Lammps’ page of documentation.

Following Aidan’s speculation about incompatibility of compilers, I tried and cross-tested almost all available IBM C++ and Fortran compilers (the XL family) on my (IBM-AIX) cluster and all the combinations ended up in the same error output. Moreover compiling reax with gfortran (and lammps with g++) also resulted in the same error on this cluster. Non-reax (basic LAMMPS without packages) however, works like a charm with the above compilers (of course with no Fortran involved).

I’ll try working with my cluster crew to sort out the error. Meanwhile, let me know if your team comes up with any fixes for the situation.


The doc pages do need to be more complete for building the REAX
package. Those compiler options were not documented b/c they
were inherited from an earlier implementation.



The HPC staff at my campus helped me sort out the problem and I’m able to compile and run LAMMPS+REAX on AIX successfully. I requested them to inform me what modifications they performed and in the following I’m pasting their response.

Thanks for your help in the matter.