[lammps-users] Problem making LAMMPS

Hello,
I am new to LAMMPS and linux, so this may be a stupid question. I am using Ubuntu. I am having trouble making LAMMPS. While in the ‘src’ directory, I typed:

make debian

(and the terminal returned)

make[1]: Entering directory /home/LAMMPS/lammps-12Feb07/src/Obj_debian' Makefile:41: angle_charmm.d: No such file or directory Makefile:41: angle_cosine.d: No such file or directory Makefile:41: angle_cosine_squared.d: No such file or directory Makefile:41: angle.d: No such file or directory (it keeps going like this for awhile) Makefile:41: update.d: No such file or directory Makefile:41: variable.d: No such file or directory Makefile:41: velocity.d: No such file or directory g++ -g -O -I/usr/lib/mpich/include/ -DFFT_FFTW -DGZIP -M velocity.cpp > velocity.d velocity.cpp:14:17: error: mpi.h: No such file or directory make[1]: *** [velocity.d] Error 1 make[1]: Leaving directory /home/LAMMPS/lammps-12Feb07/src/Obj_debian’
make: *** [debian] Error 2

Please let me know what is wrong.

Ed

Hello,
��� I am new to LAMMPS and linux, so this may be a stupid question. I am using Ubuntu. I am
having trouble making LAMMPS. While in the 'src' directory, I typed:

make debian

��� (and the terminal returned)

make[1]: Entering directory `/home/LAMMPS/lammps-12Feb07/src/Obj_debian'
Makefile:41: angle_charmm.d: No such file or directory
Makefile:41: angle_cosine.d: No such file or directory
Makefile:41: angle_cosine_squared.d: No such file or directory
Makefile:41: angle.d: No such file or directory
��� ��� (it keeps going like this for awhile)
Makefile:41: update.d: No such file or directory
Makefile:41: variable.d: No such file or directory
Makefile:41: velocity.d: No such file or directory
g++ -g -O -I/usr/lib/mpich/include/ -DFFT_FFTW -DGZIP -M velocity.cpp > velocity.d
velocity.cpp:14:17: error: mpi.h: No such file or directory
make[1]: *** [velocity.d] Error 1
make[1]: Leaving directory `/home/LAMMPS/lammps-12Feb07/src/Obj_debian'
make: *** [debian] Error 2

Please let me know what is wrong.

hi ed,

you have to adapt MAKE/Makefile.debian to match your installation.
if you plan to run in parallel, you have to install an MPI package
(LAM/MPI, OpenMPI, MPICH), if you have not already done so or
else you have to use the MPI stubs provided with LAMMPS.

cheers,
   axel.