[lammps-users] problems with building the atc lib

Hello everyone
i am pretty new to lammps and have the feb-20
when i tried to build the atc library i kept getting an error with the LammpsInterface.h file since it includes files from lammps its self
when i took it out from the list of files in the begning of the makefile everything went well
but when i tried building lammps i got the error that :

....
fix_atc.h:29:26: error: ATC_Transfer.h: No such file or directory fix_atc.h:30:29: error: LammpsInterface.h: No such file or directory In file included from fix_atc.cpp:20: fix_atc.h:29:26: error: ATC_Transfer.h: No such file or directory ....
and so fourth ,can any one please help me ?
also i have a problem when i try to build lammps with the lmlas and lapack when i add it to the USRLIB it doesn't recognize it but when i use them to build the atc it does
thanks a lot in advance !!
        Tal

You say building the library (in lib/atc, which has its own Makefile),
but your errors look like LAMMPS build errors. Does your src/MAKE/Makefile.foo
have the correct ATC settings, discussed in doc/Section_start.html? If so,
they should point to the lib dir, where those include files are. Also see
src/Makefile.package which should have got auto-edited when you
said make yes-user-atc.

Steve

Hi Tal, a quick follow-up. I was able to build LAMMPS including ATC having downloaded a fresh tarball. Given your errors, I suspect you did not do 'make yes-user-atc' since this provides the necessary linking paths.
Jeremy