[lammps-users] setting polymer flow problem!


I want to set a polymer flow problem. How to initialize the polymer chains in the simulation box?
Want to use FENE potential between the fluid-fluid molecules and LJ between the fluid-wall molecules.
I am pretty sure some one might have done some thing similar to this, looking to hear from you guys.


If you are asking how do you create a set of FENE chains,
see the tools/chain.f program or the chain tool in Pizza.py
which does the same thing. Then you will need to run MD
for a while with a pair_style soft to un-overlap the chains.

See bond_style fene for the FENE potential you ask about.
You can put a pair_style LJ with this to model the
rest of what you ask.


The file ‘chain.f’ creates set of polymer chains. But what we are interested in slightly different thing.
We want to place set of polymers in a long rectangular channel. I was trying to create a rectangular geometry first and then place the polymer chains to fill the channel volume.


Building polymer chains from scratch is tricky, especially in parallel.
So LAMMPS doesn't do it. You'd need to write your own pre-processor
that does what you want and read the coords into LAMMPS via
the read_data command. Like what chain.f does as a pre-processor.


Hi all,

I am running polymer benchmark problem. Wanted to see how the atom positions change with time.
So I use the dump command to do this but the “dump.polymer” file is empty. This is what I am doing

dump 1 all bond 100 dump.polymer

Any comments/suggestions would be greatly appreciated.


I just added this line to bench/in.chain and ran it

dump 1 all bond 100 dump.polymer

I get a file with 2 snapshots of all the bonds. If
you want atom coords you should use a dump
style of atom, not bond.


The dump file produced doesn’t contain any data. I tried bond and atom both styles
in the dump command but doesn’t produce anything in the output file.
Moreover, when tried to produce a different ‘data.chain’ file using ‘chain.f’, I get an errors saying

ERROR on proc 33: Bond atoms 6688 6689 missing on proc 33 at step 1
ERROR on proc 119: Bond atoms 7124 7125 missing on proc 119 at step 1
ERROR on proc 97: Bond atoms 77 78 missing on proc 97 at step 1
ERROR on proc 63: Bond atoms 207 208 missing on proc 63 at step 1
ERROR on proc 57: Bond atoms 417 418 missing on proc 57 at step 1
ERROR on proc 118: Bond atoms 3893 3894 missing on proc 118 at step 1
ERROR on proc 113: Bond atoms 7038 7039 missing on proc 113 at step 1
ERROR on proc 5: Bond atoms 1230 1231 missing on proc 5 at step 1

I looked at the error section on lammps website, and followed the instructions.
Varied the cut-off to as suggested but get the same kinda error.

Please post a small version of your input script and data file
that exhibits the problem.