[lammps-users] simulating water on a substrate


I am trying to simulate water (using tip4p) on a substrate. The water droplet and substrate were relaxed separately. After that, the water droplet was placed on the substrate. I tried to run the simulation (without any interaction between droplet and substrate for the trial). The minimization step worked ok, but the nvt run keeps getting the following error at the first step.

Out of range atoms - cannot compute PPPM

I set the time step as 0.00001, still same issue. Below is part of my input file

atom_style full
units real
boundary p p f
pair_style hybrid buck 12.000 lj/cut/coul/long/tip4p 7 8 5 8 0.1250 12.000
bond_style hybrid class2 harmonic

angle_style hybrid class2 harmonic

angle_style harmonic
read_data data.all2
dihedral_style multi/harmonic

timestep 0.000001
fix 1 all nvt 300.0 300.0 100.0 drag 2.0
thermo 100
thermo_style multi

group silver type 5 6
group C2 type 2
group water type 7 8

fix freeze1 silver setforce 0.0 0.0 0.0
fix freeze2 C2 setforce 0.0 0.0 0.0
fix shakewater water shake 0.0001 20 100 b 5 a 8

neigh_modify page 100000000

kspace_style pppm/tip4p 1.0e-4
kspace_modify slab 3.0
dump 1 all atom 1000 dump300Kall.C16

dump_modify 1 image yes scale no flush yes

restart 10 300KallC16.restar
minimize 1.0e-4 1000 10000
run 10



Could you send your data file as well? And perhaps simplify your input script as much as possible?