[lammps-users] strange error

Hi everybody

I've just installed the latest version of LAMMPS (24Jan2010). In order
to test it I tried to run a little test simulation (see attached files).
In doing so the following error message occurred:

LAMMPS (15 Jan 2010)
Lattice spacing in x,y,z = 4.0782 4.0782 4.0782
Scanning data file ...
  2 = max bonds/atom
  3 = max angles/atom
  10 = max dihedrals/atom
Reading data file ...
  orthogonal box = (0 0 -50) to (19.979 17.3023 150)
  1 by 1 by 4 processor grid
ERROR: Expected integer parameter in input script or data file

The same infile/datafile worked for older versions of LAMMPS.

Thanks in advance


data.layer_bpt_bcc_neutr_4x4 (49.7 KB)

in.testrun1 (1.1 KB)

I’m not sure if this fits your situation, but I’ve seen that error when I am trying to run an input file formatted with mac line endings or some other strange hidden characters. This is fixed for us by using something like wordservice to make sure that we convert all our line endings in our input and data files to unix ones:


or opening the file in vi to see if you can see any hidden characters, e.g. with a ^ in front of them.


ERROR: Expected integer parameter in input script or data file

This is a new error check, trying to protect you from using a floating
point value in your data file when LAMMPS expects an integer.
Thus if you had 2.5 it would be read as 2, which may not be
what you expect. Dihedral coeffs are a common place this "error"