[lammps-users] strange temp

hi,
I have input file the attached. When I ran it by the old version lammps(9 jan 2009) I didn’t have any problem. But When I run it by the new version lammps(7 july 2009) I have the problem related with temperature.Lammps are giving high temp values.

RESULT FİLE:
Step Temp TotEng Volume E_pair Press PotEng
0 2 2.9855366 204800 -0.013730964 0.039269945 -0.013730964
100 5.0094121 7.5122836 1423987.8 0 0.014405701 0
200 4.3373495 6.5034545 528130.11 -0.00098138771 0.033611001 -0.00098138771
300 0.95871467 1.249499 107064.88 -0.18822187 0.022222936 -0.18822187
400 2.865612 4.2267416 228437.51 -0.070626886 0.049042118 -0.070626886
500 1.9737571 2.9087317 313690.21 -0.051181047 0.029152228 -0.051181047
600 1.2723189 1.5345482 106338.58 -0.37346414 0.072004612 -0.37346414
700 2.6228492 3.8190696 236416.78 -0.11424366 0.042254968 -0.11424366
800 1.8465369 2.6154832 150475.85 -0.15364589 0.094529 -0.15364589
900 1.9893488 2.4778008 93582.903 -0.50549386 0.092214671 -0.50549386
1000 2.6466462 3.7368912 144642.57 -0.23210888 0.086398921 -0.23210888

10000 2.4118884 1.0748257 22850.112 -2.5421237 1.3367147 -2.5421237
10100 2.3645398 1.0088394 22846.589 -2.5371044 1.3229699 -2.5371044
10200 2.5105514 1.2287521 22759.938 -2.5361556 1.3475001 -2.5361556
10300 2.3767625 0.99263873 22605.56 -2.5716346 1.341734 -2.5716346
10400 2.3831607 0.95067577 22506.039 -2.6231925 1.3960008 -2.6231925
10500 2.3873058 1.0204717 22626.211 -2.5596128 1.39912 -2.5596128

43700 2.4053498 -4.314718 13308.753 -7.9218619 6.4921539 -7.9218619
43800 2.4137049 -4.3444041 13246.304 -7.9640775 6.4974199 -7.9640775
43900 2.4109036 -4.4780772 13230.539 -8.0935498 6.4738649 -8.0935498
44000 2.4091077 -4.3290677 13267.504 -7.9418469 6.4814716 -7.9418469
44100 2.3857717 -4.350458 13254.15 -7.9282418 6.5870279 -7.9282418
44200 2.3445503 -4.4729779 13207.271 -7.9889448 6.5278628 -7.9889448
44300 2.4039762 -4.4697891 13265.243 -8.0748731 6.4645281 -8.0748731
44400 2.4733085 -4.3860449 13245.074 -8.0951019 6.5524212 -8.0951019

Thanks in advance

in.ellipse.gayberne (575 Bytes)

If this is an ellipsoid model, there may have been changes to
the way degrees-of-freedom are computed for aspherical
particles. See the compute temp/asphere doc page. If your
run is doing the same dynamics but only differs in the output
Temp, then this is almost certainly the issue.

Steve

2009/7/21 ahmet yıldırım <[email protected]>:

I arranged according to the new lammps version.The problem related with temp solved but Etot,E-pair …etc values is different according to old lammps version. The arranged file is attach

21 Temmuz 2009 17:07 tarihinde Steve Plimpton <[email protected]> yazdı:

2in.ellipse.gayberne (712 Bytes)

If you can provide an input script/ data file for
a small problem and 2
log files (one for old LAMMPS, one for new) that
gives different energy on timestep 0, then I'll look
at it.

Steve

2009/7/21 ahmet yıldırım <[email protected]>:

old version
Step Temp TotEng Volume E_pair Press PotEng
0 1 1.4859028 204800 -0.013730964 0.019274828 -0.013730964
100 3.0807167 4.6199469 541073.83 0 0.023315737 0
200 2.0798482 3.0660436 127462.73 -0.052966936 0.074482962 -0.052966936
300 0.46079227 0.40648718 71975.278 -0.28453247 0.060444971 -0.28453247
400 1.3700331 1.9394011 144399.33 -0.11514683 0.031681508 -0.11514683
500 0.78535025 0.98913604 112155.39 -0.18860173 0.068346453 -0.18860173
600 0.80608822 0.58781284 70353.456 -0.62102429 0.052799206 -0.62102429
700 1.0617594 0.96844534 72138.873 -0.62380499 0.05899637 -0.62380499
800 0.85987925 0.41457271 61728.978 -0.87493127 0.072955963 -0.87493127
900 1.012192 0.38903675 52951.324 -1.1288806 0.086961043 -1.1288806
1000 0.95008801 0.07109522 47037.348 -1.3536889 0.11166924 -1.3536889
1100 0.96924021 -0.15781544 42311.874 -1.6113208 0.099457283 -1.6113208
1200 0.9775549 -0.37885228 38908.928 -1.8448266 0.12416179 -1.8448266
1300 0.9745631 -0.6545696 35638.556 -2.1160573 0.12325812 -2.1160573
1400 0.95871689 -0.89453512 33364.696 -2.3322594 0.16460932 -2.3322594
1500 0.99534827 -1.0855563 31439.353 -2.5782142 0.18436441 -2.5782142
1600 0.96319285 -1.4231766 29553.195 -2.8676132 0.19363633 -2.8676132

new version
Step Temp TotEng Volume E_pair Press PotEng
0 1 1.4859028 204800 -0.013730964 0.019274828 -0.013730964
100 3.0808833 4.6201967 541092.43 0 0.023316196 0
200 2.079792 3.0659668 127480.3 -0.052959538 0.074463392 -0.052959538
300 0.46081334 0.4065155 71975.911 -0.28453575 0.060440462 -0.28453575
400 1.3701043 1.939524 144409.26 -0.11513062 0.031682495 -0.11513062
500 0.78538686 0.98925088 112161.79 -0.18854179 0.068362456 -0.18854179
600 0.80609028 0.58778908 70351.889 -0.62105113 0.052811047 -0.62105113
700 1.0618662 0.96848238 72142.973 -0.62392813 0.058942985 -0.62392813
800 0.85991908 0.4147143 61725.603 -0.87484942 0.073161341 -0.87484942
900 1.0118918 0.38939268 52964.013 -1.1280745 0.087231374 -1.1280745
1000 0.95015367 0.071761224 47045.757 -1.3531213 0.11160004 -1.3531213
1100 0.9688753 -0.15599497 42332.246 -1.6089531 0.1003922 -1.6089531
1200 0.97694068 -0.37801017 39021.424 -1.8430634 0.11629529 -1.8430634
1300 0.97327713 -0.6550616 35609.433 -2.1146209 0.12872371 -2.1146209
1400 0.94884961 -0.90212825 33455.116 -2.3250552 0.16024672 -2.3250552
1500 0.99106081 -1.0945815 31563.655 -2.5808098 0.16278841 -2.5808098
1600 0.95833094 -1.4220477 29673.985 -2.8591932 0.1639731 -2.8591932

22 Temmuz 2009 17:12 tarihinde Steve Plimpton <[email protected]…29…> yazdı:

I provided an input script/ data file for
a small problem and 2
log files (one for old LAMMPS, one for new) that
gives different energy and velocity on timestep 0. The differences is rising when run step is enhanced.
The files is attach

22 Temmuz 2009 17:27 tarihinde ahmet yıldırım <[email protected]…24…> yazdı:

new_in.ellipse.gayberne (710 Bytes)

new_log.lammps (4.17 KB)

old_in.ellipse.gayberne (573 Bytes)

old_log.lammps (3.94 KB)

The 2 runs appear to give identical answers for everything
on timestep 0, then slowly drift apart. I'm guessing that
for long times, they give identical results in a statistical (time-averaged)
sense? If so, I don't consider this a bug. There are a variety
of reasons why small changes to the code can cause round-off and
other changes that induce this. If you're worried about it, I suggest
you diff source files for the relevant features (pair potential, aspherical
integrators and temperature, and fixes, etc) between the old
and new codes and look for differences. I don't remember at this
point all the changes that were made.

Steve

2009/7/22 ahmet yıldırım <[email protected]>: