[lammps-users] Trouble compiling LAMMPS on Linux cluster

I am a new user to LAMMPS and am having trouble compiling the program on my lab’s Linux cluster. I have been able to successfully compile and run LAMMPS (without MPI) on my Windows PC. My Linux cluster is running Redhat Linux 4 on Navion-A dual Opteron nodes. The cluster has been configured with MPICH2.

The following is my makefile:

Makefile_Microway.log (191 KB)


I use LAMMPS on a linux cluster with MPI. I suggest trying the following:

cp Makefile.linux Makefile.xyz # where xyz is your machine name
Change linux to your machine name on line 1.
Append -lm to USRLIB.
Use a different compiler. I use mpig++ instead of mpicxx
Make sure your CCFLAGS -I arguments and LINKFLAGS -L arguments have all the necessary libraries.

Hope this helps.
– Al Franz

I have tried complied LAMMPS using MPICH2. It failed. While, MPICH1 works.


There is nothing in LAMMPS that requires MPICH2 functionality,
so I suggest the original poster (Tim Kokan) try building against
a MPICH1 library ...


Compiling using MPICH1 worked for me too.

Thanks, Tim