[lammps-users] Unrecognized fix style 'scgmc'


I am using the LAMMPS version 29Oct2020. I am currently trying to perform a hybrid MD/MC simulation in which I use the ‘vcsgc’ LAMMPS package. After installing the package in Ubuntu and recompiling Ubuntu, I tested the example LAMMPS code that was already present in the package folder to see if it is working. But this gave me an error " Unrecognized fix style ‘scgmc’ ". I followed the installation instructions on the ‘vcsgc-lammps’ page to install the ‘vcsgc’ package. I tried the installation procedure a few times, but it gives me the same error every time I run the example code. What am I doing wrong? Thanks in advance!


Either you are using the wrong executable (i.e. not the one that was freshly compiled).
Or your compilation failed and you didn’t notice (so the executable is the original one that didn’t contain the new fix).
Or you followed the instructions for installation of that external package incorrectly (multiple times)
Or the package is not compatible with that specific LAMMPS version without modifications.

Neither of these cases can be confirmed from remote with the limited information you provide and for most of those you will most likely need to contact the developers of that external package directly. It is not guaranteed that they follow this mailing list. If they have a GitHub page for their software you can usually submit an Issue there.