'limit' and 'skip' parameters have been renamed. Please update your API client to the newest version

MPRestError: REST query returned with error status code 400 on URL https://api.materialsproject.org/materials/?
‘limit’ and ‘skip’ parameters have been renamed. Please update your API client to the newest version.

Hello all,

I have been working around this problem for couple of days. I tried uninstalling and reinstalling mp-api.

The new api hasn’t been helping much to gain access to the database.

Any advice would be appreciated

followed by upgrade.

Hi Nik,

this might have to do with the python version you’re running, see Error while installing mp_api version 0.26.3 on google colab · Issue #664 · materialsproject/api · GitHub

HTH
Patrick

1 Like

Thank you, it indeed was my python version. I assumed my python version was beyond 3.8. When I looked into the pip list, it was 3.7. Now it makes sense why the api was not upgrading beyond 18.8