Limited or No output in log file due to variable formula

Dear Steve, Users,

I have a input script in which I am updating the coordinates of the atoms in a certain way. It has to be done iteratively for several steps. The minimal steps in the script are as follows

Dear Steve, Users,

I have a input script in which I am updating the coordinates of the atoms in
a certain way. It has to be done iteratively for several steps. The minimal
steps in the script are as follows

---------

[...]

While, there is no error, my log file is getting huge because of all the
variable calculations lines it writes. As I am calculating 'z' values for
each atom at multiple steps, the following portion is written for each atom
for each timestep in the log file. Is there a way to supress that or some
other workaround?

try "echo none" or "-echo none" at the command line.

axel.

Thanks Axel…

-echo none worked.

One more help if possible.

As you can see from the script snippet above, as I am changing the z coordinates of the atoms individually, I am also getting following lines “natoms” times even after I put -echo none in the command line.
“1 settings made for z”

Is there a way to suppress that?

Best regards,
Vikas

Thanks Axel..
-echo none worked.

One more help if possible.
As you can see from the script snippet above, as I am changing the z
coordinates of the atoms individually, I am also getting following lines
"natoms" times even after I put -echo none in the command line.
"1 settings made for z"

Is there a way to suppress that?

only via "log none", which will turn off writing to the log file entirely.

axel.

One the other hand, there is always a possibility to turn any output off in the source code.

Regards,
Oleg.

One the other hand, there is always a possibility to turn any output off in the source code.

if you down this lane, it might be even more attractive to have a "log
pause" and "log continue" command and the same for screen to suspend
output and re-enable. that would allow people to have their cake *and*
eat it.

axel.

It's almost the same as log none/log, I think. Isn't it?

24.09.13, 23:11, "Axel Kohlmeyer" <[email protected]>":

It's almost the same as log none/log, I think. Isn't it?

no. log none will close the file and then upon re-opening it will be
truncated. the alternative would be to add an append option.

axel.

It's almost the same as log none/log, I think. Isn't it?

no. log none will close the file and then upon re-opening it will be
truncated. the alternative would be to add an append option.

in fact, that would be much easier to do. i think, i'll just do it and
send it to steve later... :wink:

axel.

That's why there was "almost". Agree.

Thank you guys for the suggestions. I was planning to comment out the line in the source code. I will wait for Axel’s update then and download the patch.

Regards,
Vikas

Thank you guys for the suggestions. I was planning to comment out the line
in the source code. I will wait for Axel's update then and download the
patch.

here you are. pretty simple, but effective.

enjoy,
    axel.

lammps-log-append.diff.gz (974 Bytes)

Thanks Axel,

I worked. However, I did not get why you added additional class in class FixRespa:

Best Regards,
Vikas

Thanks Axel,

I worked. However, I did not get why you added additional class in class
FixRespa:

that was an oversight. some leftover code from a debugging session.