making LAMMPS with MPI on mac 10.6.8

Hi Bruce,

Why do you even install MPICH? If you have a recent version of Xcode installed on your machine (which you should!), then you should be able to make LAMMPS by having the following in Makefile.mac_mpi:

CC = mpic++
CCFLAGS = -O -MMD
LINK = mpic++

MPI_INC = -DOMPI_SKIP_MPICXX

(I only quote the lines that are different from standard.)

Then just type "make mac_mpi" while in /src, and it should work fine. (It does on my Mac 10.6.8 at least.)

Sincerely,
Christer H. Ersland.