MANYBODY package efficiency problem

Dear lammps users,

I was using lammps manybody package to run NVT simulations with a hybrid force field of Stillinger-weber and OPLSUA. The simulation box is 808080 Angstroms with

10 decane chains (using OPLSUA force field) and 16923 monatomic water (using SW potential). At the beginning, the loop time on 40 procs for 1000 steps is about 8 secs. After several thousands of steps, the loop time jump to 20 secs for 1000 steps.

Here are the final statistic results for loop time:

Loop time of 175054 on 40 procs (40 MPI x 1 OpenMP) for 10000000 steps with 17023 atoms

Pair time () = 47718.6 (27.2594) Bond time () = 15.0816 (0.00861544)
Neigh time () = 1993.23 (1.13864) Comm time () = 65109.2 (37.1939)
Outpt time () = 141.999 (0.0811176) Other time () = 60075.4 (34.3183)

As you can see, the communication time and other time are abnormal. When I build SW parameter file, I have to specify parameters for all permutations of the two elements interacting in three-body configurations. I am not sure if this could cause efficiency problem or maybe hybrid force field is the issue.

Does anyone have any suggestions? Thank you so much!

Best,
Pu Du

Dear lammps users,

I was using lammps manybody package to run NVT simulations with a hybrid
force field of Stillinger-weber and OPLSUA. The simulation box is 80*80*80
Angstroms with

10 decane chains (using OPLSUA force field) and 16923 monatomic water (using
SW potential). At the beginning, the loop time on 40 procs for 1000 steps
is about 8 secs. After several thousands of steps, the loop time jump to 20
secs for 1000 steps.

Here are the final statistic results for loop time:

Loop time of 175054 on 40 procs (40 MPI x 1 OpenMP) for 10000000 steps with
17023 atoms

Pair time (\) = 47718\.6 \(27\.2594\) Bond time \() = 15.0816 (0.00861544)
Neigh time (\) = 1993\.23 \(1\.13864\) Comm time \() = 65109.2 (37.1939)
Outpt time (\) = 141\.999 \(0\.0811176\) Other time \() = 60075.4 (34.3183)

As you can see, the communication time and other time are abnormal. When I
build SW parameter file, I have to specify parameters for all permutations
of the two elements interacting in three-body configurations. I am not sure
if this could cause efficiency problem or maybe hybrid force field is the
issue.

no. my first suspicion would be, that you are running some additional
fixes and computes that may be causing the issues.
the second worry would be, that your output indicates, that you are
not using a recent version of LAMMPS, so please update (best to the
very latest developer version) and try again.

since you are the second person reporting unusually large Comm times
with SW potentials, we should make certain, that it is actually the SW
potential causing the problem.
have you visualized your trajectories? do they look meaningful?

axel.

Dear Dr. Kohlmeyer,

Thank you so much for your reply.

The only fix I have is NVT and no additional computes. I will try the latest version of LAMMPS and see what will happen.

Also, the trajectories look like what I am expecting.

Thanks,
Pu Du