Moltemplate-Compass

Hi Andrew
Thank you for your reply. Then you didn’t similar problem in running hexadecane with compass. So it is just my problem that I don’t know where it is come from!! Let me say my installation method…
I installed it based on the instruction in the manual. I am using Linux bash shell. After downloading and unzipping the Moltemplate, I added the path in bashrc as following:
……vi .bashrc
datauri-file.png

My Moltemplate version is 2018.6.27, and I haven’t had such problem with OPLSAA. My constructed system was done well with OPLSAA.
However, do you think there has been sort of issues in my installation?

Best Regards
Katerina

I want to use compass forcefield and I have a problem that have confronted with both to construct my model and testing one of the example of moltemplate for compass ( hexadecane). After typing

  • moltemplate.sh -atomstyle “full” system.lt

I faced with the following error:
---- Paranoid checking: —
Possible error near “compass_published.lt”, line 154
The wildcard symbol, “", is not recommended within a “pair_coeff” command.
It is safer to specify the parameters for each bond type explicitly.
You CAN use "
” wildcards, but you must disable syntax checking. To get
past this error message, run moltemplate.sh using the “-nocheck” option.

Hi Katerina
I am not able to reproduce this problem.
Are you using the latest version of moltemplate?

Did you follow the installation instructions?

then I added -nocheck, and after a not complete performing I faced with another error:

Loking up partial charge contributions from bonds
python: can’t open file ‘/usr/local/bin/charge_by_bond.py’: [Errno 2] No such file or directory

Weird.
“charge_by_bond.py” should not end up in /usr/local/bin
This sounds like an installation issue.

How did you install moltemplate?

Andrew