MPI platform

If it's on a laptop, I suspect you don't actually /need/ MPI---I run
LAMMPS on my laptop all the time without it. Try "make serial" in the
build directory (you may have to do a "make stubs" first). You may have
to edit MAKE/Makefile.serial and change "g++4" to simply "g++" to get it
working---someone changed that some time ago and it's now broken except
for very old distributions (such as RHEL 4 and CentOS 4) that still use
gcc 3.x but have a gcc 4.x preview included as gcc4 and g++4.

If you do need MPI for some reason, I suggest using "make openmpi" after
installing OpenMPI as outlined below.

I don't run Ubuntu personally (I'm very familiar with Fedora, RHEL, and
CentOS, but not Debian-based distros), but I think the following sequence
of commands will work for you (commands starting with '#' should be run as
root or with sudo; those with '$' should be as yourself):

# apt-get install openmpi-bin openmpi-doc libopenmpi-dev
// if " which mpicc" returns a path instead of an error, skip the next // three steps module avail
module load openmpi // or whatever the name you found was module initadd openmpi // if you want it EVERY TIME you start a shell
cd \[/path/to/LAMMPS/build/directory\] make openmpi
// If the above command fails, it might be because you're missing the FFTW
// libraries; you can install them, or edit MAKE/Makefile.openmpi and
// remove the -lfftw flag and change the -DFFT_FFTW flag to -DFFT_NONE
mkdir \-p \~/bin cp lmp_openmpi ~/bin

You should now have lammps working on your laptop.

Note that if the Ubuntu DEB does indeed use environment modules, you'll
have to load that module before the OpenMPI build of LAMMPS will go.

Good luck!

Karl D. Hammond
University of Tennessee