MPRester get_entries_in_chemsys

Hi, I am not sure why, but the MPRester get_entries_in_chemsys seems quite unstable.
The specific problem is when I do " qe.get_entries_in_chemsys([element lists…]) "
Until yesterday, it has always worked fine. However, now I do not receive the queried data and keep getting the following error.

File “/home/kyujung/miniconda3/lib/python3.7/site-packages/pymatgen/ext/”, line 168, in _make_request
raise MPRestError(data[“error”])
pymatgen.ext.matproj.MPRestError: [Errno 113] No route to host

  • I have tried multiple API keys, but all same problem.
  • I suspected there may be a connection problem, but get_entries_by_mpid works fine, so I think connection would not be an issue.
  • I have tried “get_entries” instead of “get_entries_in_chemsys” with the same elements and it does work.
  • I have tried manually querying multiple entries by “get_entries_by_mpid” and the first query of a single entry works fine, but the error consistently pops up from the query of the second entry.
    Is there something new that I have changed regarding “get_entries_by_chemsys”? Or perhaps querying multiple entries currently is not stable for some reason?
    Thank you!



Hi @KyuJung_Jun,

Thanks for reporting this, the team is aware of the issue and we’re looking into it.



Thank you for your reply. I think it works now!

Yes, I can confirm this has been fixed thanks to @Shreyas_Cholia and @dwinston. Please do let us know if you encounter a similar issue in future however.

1 Like