NaN Issue

Dear Axel,

Many thanks for your clarification. I believe this is caused by the particles being generated in MATLAB as I used to run jobs with particles randomly generated within the same box confines but with LAMMPS itself.

In these calculations, however, I have to impose Maxwell-Boltzman velocity profiles in a data file. On the other hand, it seems not plausible to generate particles in LAMMPS but use external velocity values.

Now, could you kindly advise an effective way out of this trap?

Would you recommend still generating particles in MATLAB but increasing box dimensions to prevent overlapping?

Would reduction of the particle initial radii work?

What would you suggest?


Mohammad E. Torki

Random positions are random regardless how you create them and overlaps are always possible. the delete_atoms command has an option to eliminate such close contacts. But in your data file particles are extremely close. the fact that the neighbor list built is complaining about too many neighbors is a strong indication. granular particles generally have very few neighbors in the neighbor list. another indication is that the command “delete_atoms overlap 0.01 all all” will delete more than half the particles. have you visualized your initial configuration?

Also when starting from random positions, the distribution of the (initial!) velocities is pretty much meaningless, you will be in a high-potential energy configuration anyway and within a few time steps that will be the property that will be predominantly responsible for the velocity distribution.