NEB images not generating properly

Hi all,

I am trying to run an NEB simulation for simple 3 Argon atoms on lammps-16th March 2018 version. When I run the calculation, at the first step before the calculation starts, my RDT=0, RD1=0 and all RDN (N = 2 to N) = -nan. The Potential energy of all my images comes out to be the same (as initial) at all the steps.
This means that all the images have the same initial configuration (which I do not want). There is probably some small thing that I am doing wrong somewhere, but I can't seem to figure out what. I ran the example script given. It runs perfectly and I can't seem to figure out any difference in the two which would cause such a mistake to happen. I am attaching my script here for your reference.

units real
boundary p p p
atom_style molecular

pair_style lj/cut 10.215
pair_coeff * * 1 1

minimize 1.0e-6 1.0e-4 1000 10000
reset_timestep 0
timestep 0.05

neigh_modify every 10 delay 20 check yes
thermo 300
fix 1 all neb 1.0 parallel ideal
min_style quickmin
neb 0.0 0.1 1000 1000 100 final last.txt
dump 1 all atom 1000 dump

Thanks a lot for your time and help in advance,
Madhur Aggarwal