new user

Yesterday I’ve started to use openkim and I’ve used the vagrant method downloading Vagrantfile like suggested in documentation. But I’m in trouble with kimitems :

I’ve tried to make the first step to check that all was ok and tried to use

[email protected]:~$ kimitems install EAM_Dynamo_Ackland_Bacon_Fe__MO_142799717516_001
Traceback (most recent call last):
File “/home/openkim/openkim-pipeline/tools/kimitems”, line 14, in
import kimapi
File “/home/openkim/openkim-pipeline/kimapi.py”, line 13, in
from packaging import version
ImportError: No module named packaging

so problem seems to be taht in kimapy.py he hasn’t able to resolve the packaging import.

I’m sure that is my fault if someone pls may give a suggestion I’d appreciate a lot

thx

Paola

Hi Paola,

Can you please tell me the status of the following commands run on the virtual machine?

cd ~/openkim-pipeline
git rev-parse HEAD

As well as

cd ~/openkim-pipeline-setup
git rev-parse HEAD

It seems that you have downloaded the development branch somehow. Perhaps I actually merged it into the mainline, which would have been a mistake. Thank you