Newbie on python

Sorry for the stupid question.

I need to user Win7 32bit.

  • I installed on C:\Python27 the 2.7.12 release. PATH contains C:\Python27

  • I Installed Fireworks also by pip

Now, if I run “lpad -version”

c:\Python27\Scripts>python lpad version

(u’FireWorks version:’, ‘1.3.3’)

(u’located in:’, ‘C:\Python27\lib\site-packages’)

c:\Python27\Scripts>lpad version

“lpad” non è riconosciuto come comando interno o esterno,

un programma eseguibile o un file batch. (lpad is not known as executable)

What did I miss?

Riccardo

Hi Ricardo

I don’t know much about windows but there are three possible issues I can think of. Otherwise, I might need to defer to any Windows users on the list.

  1. The pip command didn’t install the “lpad” script file into your $PATH. So you want to check that lpad is in your PATH, using something like “which lpad” or equivalent, which should display where the script file is located in your PATH.

  2. The “lpad” script is in your PATH, but it does not have execution permission. So, you want to use the “chmod” command to add execution permission to “lpad”

  3. Both of the above are true, but the “lpad” command doesn’t know what executable to use to run it. In the first line of the lpad script, you will notice it says “#!/usr/bin/env python”. This tells bash to use the Python executable to run the script. You might need to modify the hashbang for python if it is different for Windows.

Best,

Anubhav

···

On Mon, Aug 8, 2016 at 8:41 AM, RICCARDO RUSSO [email protected] wrote:

Sorry for the stupid question.

I need to user Win7 32bit.

  • I installed on C:\Python27 the 2.7.12 release. PATH contains C:\Python27
  • I Installed Fireworks also by pip

Now, if I run “lpad -version”

c:\Python27\Scripts>python lpad version

(u’FireWorks version:', ‘1.3.3’)

(u’located in:', ‘C:\Python27\lib\site-packages’)

c:\Python27\Scripts>lpad version

“lpad” non è riconosciuto come comando interno o esterno,

un programma eseguibile o un file batch. (lpad is not known as executable)

What did I miss?

Riccardo

You received this message because you are subscribed to the Google Groups “fireworkflows” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

Visit this group at https://groups.google.com/group/fireworkflows.

To view this discussion on the web visit https://groups.google.com/d/msgid/fireworkflows/6959d66e-b5ed-4ee4-96fc-c4e52c919dd4%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.


Best,
Anubhav

I think that pip was fine as you can see…

···

C:\Python27\Scripts>more lpad
#!c:\python27\python.exe
from fireworks.scripts.lpad_run import lpad
if name == ‘main’:
lpad()

Il giorno lunedì 8 agosto 2016 18:11:41 UTC+2, ajain ha scritto:

Hi Ricardo

I don’t know much about windows but there are three possible issues I can think of. Otherwise, I might need to defer to any Windows users on the list.

  1. The pip command didn’t install the “lpad” script file into your $PATH. So you want to check that lpad is in your PATH, using something like “which lpad” or equivalent, which should display where the script file is located in your PATH.
  1. The “lpad” script is in your PATH, but it does not have execution permission. So, you want to use the “chmod” command to add execution permission to “lpad”
  1. Both of the above are true, but the “lpad” command doesn’t know what executable to use to run it. In the first line of the lpad script, you will notice it says “#!/usr/bin/env python”. This tells bash to use the Python executable to run the script. You might need to modify the hashbang for python if it is different for Windows.

Best,

Anubhav

On Mon, Aug 8, 2016 at 8:41 AM, RICCARDO RUSSO [email protected] wrote:

Sorry for the stupid question.

I need to user Win7 32bit.

  • I installed on C:\Python27 the 2.7.12 release. PATH contains C:\Python27
  • I Installed Fireworks also by pip

Now, if I run “lpad -version”

c:\Python27\Scripts>python lpad version

(u’FireWorks version:', ‘1.3.3’)

(u’located in:', ‘C:\Python27\lib\site-packages’)

c:\Python27\Scripts>lpad version

“lpad” non è riconosciuto come comando interno o esterno,

un programma eseguibile o un file batch. (lpad is not known as executable)

What did I miss?

Riccardo

You received this message because you are subscribed to the Google Groups “fireworkflows” group.

To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].

To post to this group, send email to [email protected].

Visit this group at https://groups.google.com/group/fireworkflows.

To view this discussion on the web visit https://groups.google.com/d/msgid/fireworkflows/6959d66e-b5ed-4ee4-96fc-c4e52c919dd4%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.


Best,
Anubhav