No rule to make reax_defs.h

This is not really a LAMMPS issue, but a mixed-language support issue that
is different on every machine. So you should consult your local platform
expert. That said, the standard trick for finding the necessary FORTRAN
libraries is to compile a test program using your FORTRAN compiler,
turning on maximum verbosity (e.g. gfortran -v). Take all the -L and -l
options that show up and stick them in Makefile.lammps. If that works,
then start deleting them one by one, to find out which ones are really
necessary. You should then end up with something fairly reasonable like:
[[email protected] reax] more Makefile.lammps
# Settings that the LAMMPS build will import when this package library is
used

reax_SYSINC =
reax_SYSLIB = -lifcore -lsvml -lompstub -limf
reax_SYSPATH = -L/opt/intel/fce/10.0.023/lib

Aidan