(no subject)

I am doing a tensile stress on C-CH2 on lammps. But while running simulation it gets stuck at

Per MPI rank memory allocation (min/avg/max) = 113.3 | 113.3 | 113.3 Mbytes
Step Lx Ly Lz Press Pxx Pyy Pzz PotEng Temp
0 22 22 45 nan nan nan nan nan 300
how to solve this problem?

The potential energy at Step 0, when the simulation box has not been deformed at all, is NaN (i.e. not a number).
So, there is something wrong with the initial configuration or / and with the assignment of the force field.

Can you run without any issues a simulation of the same system without deformation, for instance “standard” NVE?

Evangelos

Στις Τρί, 27 Αυγ 2019 στις 10:12 μ.μ., ο/η Shad, Fuzail <fuzailshad@…8639…> έγραψε:

NVE worked fine. But if i use NPT or Thermal this problem arise

Στις Τρί, 27 Αυγ 2019 στις 10:29 μ.μ., ο/η Shad, Fuzail <fuzailshad@…8639…> έγραψε:

NVE worked fine. But if i use NPT or Thermal this problem arise

This means that the problem you are facing has nothing to do with the tensile stress. In my opinion, the first step is to run a stable NPT/NVT simulation before applying any stress on the system.
If you are sure that you have assigned the force field parameters properly, then try an energy minimization and subsequently a NVT simulation with a very low damping parameter. This way you will obtain a configuration with much lower energy than the one you are using now.

Hope it works for you
Evangelos

NVE worked fine. But if i use NPT or Thermal this problem arise

please note, that you cannot couple NPT cell dimension changes to the same dimensions that you also deform. doing this could result in exactly the symptoms you are observing. it would be easier to discuss this, if you would provide your input file and also state which version of LAMMPS exactly you are using.

axel.