Out of range atoms error after many timesteps

Hello all.

I am working on electrosmotic flows through channels. I have placed NaCl solution between charged walls and trying to run the system for 4 ns to reach equilibration. However, after about 50000 timesteps, the simulations stops with out of range atoms. The dump file shows the atoms moving out through x direction (periodic). I have tried different parameters for timesteps, thermostatting etc but the problem persists, only the timestep at which it occurs varies.

Kindly suggest how to debug my problem. I have been struggling with it for a long time. Please find attached the input script, geometry file and snapshot of system near the error point.

Regards,

Manash

geometry.data (558 KB)

input.in (4.52 KB)

snap_system_51800.jpeg

Hello all.
  I am working on electrosmotic flows through channels. I have placed NaCl
solution between charged walls and trying to run the system for 4 ns to
reach equilibration. However, after about 50000 timesteps, the simulations
stops with out of range atoms. The dump file shows the atoms moving out
through x direction (periodic). I have tried different parameters for
timesteps, thermostatting etc but the problem persists, only the timestep at
which it occurs varies.
Kindly suggest how to debug my problem. I have been struggling with it for a
long time. Please find attached the input script, geometry file and snapshot
of system near the error point.

look at your visualization. where are the water molecules?
i see what looks like bead-spring polymer chains.

i'd say, there is something very wrong with your geometry or topology
in your data file.

axel.