Out of Range atoms

Hello all,

I’m trying to simulate war molecules confined in a graphene channel and when ever I run the simulation, I get the following error :

‘‘Out of range atoms - cannot compute PPPM’’

I’m using the p p f boundary condition and with the kspace_modify command. I had noticed that when I run the simulation with ppp boundary conditions it runs for more number of timesteps.

Could any one please suggest how to tackle this problem?

Please find the input scrip and data file attached.

Thanks and Regards,


try2.in (5.9 KB)

system.data (203 KB)

See Section_errors.html of the manual, which says:

One or more atoms are attempting to map their charge to a PPPM grid
point that is not owned by a processor. This is likely for one of two
reasons, both of them bad. First, it may mean that an atom near the
boundary of a processor’s sub-domain has moved more than 1/2 the
“neighbor skin distance”_neighbor.html without neighbor lists being
rebuilt and atoms being migrated to new processors. This also means
you may be missing pairwise interactions that need to be computed.
The solution is to change the re-neighboring criteria via the
“neigh_modify”_neigh_modify command. The safest settings are “delay 0
every 1 check yes”. Second, it may mean that an atom has moved far
outside a processor’s sub-domain or even the entire simulation box.
This indicates bad physics, e.g. due to highly overlapping atoms, too
large a timestep, etc.