pair_style gauss command


I have a simple model of two ions in the box. I decrease the separation of two ions and calculate the force on each ion. I am using Implicit solvent model but I added the gaussian potential to represent the solvation shell of water molecules(following paper by Pablo, JCP 135, 165104 (2011) ). I used the following commands (file is attached)

pair_style hybrid/overlay lj/cut/coul/long 10 coul/diel 10 gauss 18


pair_coeff 1 2 coul/diel 66.8 3.68 1.0

the results of the force shows that the force on each ion with and without the gaussian potential is the same which means this potential has not had any contribution in the force on each ion!!

I don’t understand the reason! I really appreciate if you help me with this problem.


ts.txt (670 Bytes)

in5.simple (2.68 KB)

try a test where you only specify pair_style gauss

with the same coeff settings and see if the force
is non-zero. If that works they try pair hybrid/overlay
with 2 pair styles (one being gauss) and see if that


Hi Steve,

Thanks for your reply but considering only pair_style gauss (not any other potential),

pair_style gauss 18

pair_coeff 1 1 0.0 1.0
pair_coeff 1 2 5 6.1 0.5
pair_coeff 2 2 0.0 1.0

it gives me the following error

ERROR: KSpace style is incompatible with Pair style (…/kspace.cpp:157) ( with Ewald)

ERROR: KSpace style is incompatible with Pair style (…/kspace.cpp:159) (with pppm )

If I consider lj/cut/coul/long and gauss (using pair_style hybrid/overlay lj/cut/coul/long 10 gauss 18) , the code runs but again gaussian potential does not have any contribution in the force on each ion!!


Are you sure that you want the gauss pair style and not gauss/cut?


What is the point of including a kspace style, when your pair style doesn't even consider charges? Remember you want to run test with as few components as possible.


Just turn off the kspace style. I want
to be convinced that pair gauss should

be producing non-zero force and is producing

zero force. I doubt the issue has anything to
do with pair hybrid.


Hi Steve and Alex,

Thanks for your responds. That was my mistake using gauss instead of gauss/cut.
It is working quite well with gauss/cut command now.