Problem in pair_style hybride

Dear all,
I’m using hybrid pair_style to define interatomic interactions by using the following command in the latest version of lammps,

pair_style hybrid eam/alloy table spline 3001 table spline 3001
pair_coeff * * eam/alloy copper.alloy Cu NULL
pair_coeff 1 2 table a.pot He Cu 3.6
pair_coeff 2 2 table b.pot He He 3.6

But, I’m experiencing the following error,

lattice fcc $a origin 0.01 0.01 0.01 orient z 1 -1 -1 orient x 1 1 0 orient y 1 -1 2 spacing 1 1 1
lattice fcc 3.615 origin 0.01 0.01 0.01 orient z 1 -1 -1 orient x 1 1 0 orient y 1 -1 2 spacing 1 1 1
Lattice spacing in x,y,z = 3.615 3.615 3.615
read_restart restart.100000
WARNING: Restart file used different # of processors (…/read_restart.cpp:717)
triclinic box = (0.186085 -0.554397 -0.333127) to (613.3 142.233 138.083) with tilt (2.37761 22.8205 -1.29343)
10 by 4 by 3 MPI processor grid
ERROR: Unknown pair style (…/force.cpp:240)

Could anybody please direct me if i’m doing any wrong? Is it may be due to my older restart file?

Best,
Paul

Dear all,
I'm using hybrid pair_style to define interatomic interactions by using
the following command in the latest version of lammps,

pair_style hybrid eam/alloy table spline 3001 table spline 3001
pair_coeff * * eam/alloy copper.alloy Cu NULL
pair_coeff 1 2 table a.pot He Cu 3.6
pair_coeff 2 2 table b.pot He He 3.6

But, I'm experiencing the following error,

lattice fcc $a origin 0.01 0.01 0.01 orient z 1 -1 -1 orient x
1 1 0 orient y 1 -1 2 spacing 1 1 1
lattice fcc 3.615 origin 0.01 0.01 0.01 orient z 1 -1 -1 orient
x 1 1 0 orient y 1 -1 2 spacing 1 1 1
Lattice spacing in x,y,z = 3.615 3.615 3.615
read_restart restart.100000
WARNING: Restart file used different # of processors
(../read_restart.cpp:717)
  triclinic box = (0.186085 -0.554397 -0.333127) to (613.3 142.233
138.083) with tilt (2.37761 22.8205 -1.29343)
  10 by 4 by 3 MPI processor grid
ERROR: Unknown pair style (../force.cpp:240)

Could anybody please direct me if i'm doing any wrong?

​difficult to say. was that restart generated with a different pair style?​

Is it may be due to my older restart file?

​possible. you could try to convert the restart into a data file and then
use that as a starting point​.

axel.

The issue has been solved. It was due to my old restart file, lammps data file works fine.

Thanks.