problem installing on Stampede2


I am trying to install atomate in Stampede2 cluster. (python 3.6.3). I followed instructions from

The “lpad reset” command was successful with the followiing output -
(atomate_env) login2.stampede2(1252)$ lpad reset
Are you sure? This will RESET 0 workflows and all data. (Y/N)Y
2018-01-19 22:37:23,225 DEBUG RESTARTED fw_id, launch_id to (1, 1)
2018-01-19 22:37:23,225 INFO Performing db tune-up
2018-01-19 22:37:23,225 DEBUG Updating indices…
2018-01-19 22:37:24,078 INFO LaunchPad was RESET.


I followed the instructions and finally came to the Run a test workflow step (option 2 - i set up API key for materials project - so that should not be an issue)

atomate_env) login2.stampede2(1262)$ atwf add -l vasp -p wf_structure_optimization -m mp-149
/work/03554/tg828535/stampede2/atomate/atomate_env/lib/python3.6/site-packages/pymatgen/io/ UserWarning: Please install optional dependency pybtex if youwant to extract references from CIF files.
warnings.warn(“Please install optional dependency pybtex if you”
Traceback (most recent call last):
File “/work/03554/tg828535/stampede2/atomate/atomate_env/bin/atwf”, line 19, in
from atomate.vasp.powerups import add_namefile, add_tags
File “/work/03554/tg828535/stampede2/atomate/atomate_env/lib/python3.6/site-packages/atomate/vasp/”, line 12, in
from atomate.common.firetasks.glue_tasks import DeleteFiles
File “/work/03554/tg828535/stampede2/atomate/atomate_env/lib/python3.6/site-packages/atomate/common/firetasks/”, line 16, in
from boltons.fileutils import copytree
ModuleNotFoundError: No module named ‘boltons’


So, I am missing the boltons package and the pybtex (optional). I install them through

(atomate_env) login2.stampede2(1263)$ pip install boltons pybtex
Collecting boltons
Using cached boltons-17.2.0-py2.py3-none-any.whl
Collecting pybtex
Requirement already satisfied: PyYAML>=3.01 in ./atomate_env/lib/python3.6/site-packages (from pybtex)
Collecting latexcodec>=1.0.4 (from pybtex)
Using cached latexcodec-1.0.5-py2.py3-none-any.whl
Requirement already satisfied: six>=1.4.1 in ./atomate_env/lib/python3.6/site-packages (from latexcodec>=1.0.4->pybtex)
Installing collected packages: boltons, latexcodec, pybtex
Successfully installed boltons-17.2.0 latexcodec-1.0.5 pybtex-0.21


I ran the option 2 command again but I got this error now.

(atomate_env) login2.stampede2(1274)$ atwf add -l vasp -p wf_structure_optimization -m mp-149
Traceback (most recent call last):
File “/work/03554/tg828535/stampede2/atomate/atomate_env/bin/atwf”, line 236, in
args.common_param_updates = ast.literal_eval(args.common_param_updates) # str->dict
File “/opt/apps/intel17/python3/3.6.3/lib/python3.6/”, line 85, in literal_eval
return _convert(node_or_string)
File “/opt/apps/intel17/python3/3.6.3/lib/python3.6/”, line 84, in _convert
raise ValueError('malformed node or string: ’ + repr(node))
ValueError: malformed node or string: {}


I also tried supplying my own POSCAR (option 4) but I get he same error.

Can anyone suggest a solution for this? I saw some people followed this instructions and was able to install and run. I am not sure why I am getting this error.

ASM Jonayat


Thanks for reporting the problem. I just pushed a change so boltons will be installed automatically next time. Not sure if pybtex is really needed but we can make that a requirement in the future as well if it seems needed.

Regarding the main problem with atwf, Shyam - this looks to me related to your recent changes to atef and common_param_updates - can you look into this?