Problem (maybe bug) with comm_style

Hi,

I just notice that while specifying comm_style only works well, specifying comm_modify will cause MPI errors. Test input files together with outputs are attached.

The system is very simple, a single profile chain with atoms connecting their nearest neighbours with harmonic bonds. No pair interaction are presented. The system is run under NVE. Lammps version 13May2014 is used built with openmpi and Intel compiler 2013 (version: parallel_studio_xe_2013_sp1_update2)

I notice that on the doc for comm_style it says tiled style hasn’t been implemented yet. If what I report is right, then however at least to me, intuitively I’ll set comm_style brick, which will cause the error mentioned above. I would suggest at present remove the doc for comm_style or on its doc say that this commands not working yet.

Best

Ming

example.tar.gz (19.5 KB)

Hi,

I just notice that while specifying comm_style only works well, specifying
comm_modify will cause MPI errors. Test input files together with outputs
are attached.

​there are no MPI errors, but a segmentation fault, and that happens
because comm_style is specified after you have defined the simulation box,
but in its current implementation it should be specified before and then
the segmentation fault will go away. there are several low-level settings
in LAMMPS that can only be set once and before the box is defined.

The system is very simple, a single profile chain with atoms connecting
their nearest neighbours with harmonic bonds. No pair interaction are
presented. The system is run under NVE. Lammps version 13May2014 is used
built with openmpi and Intel compiler 2013 (version:
parallel_studio_xe_2013_sp1_update2)

I notice that on the doc for comm_style it says tiled style hasn't been
implemented yet. If what I report is right, then however at least to me,
intuitively I'll set comm_style brick, which will cause the error mentioned
above. I would suggest at present remove the doc for comm_style or on its
doc say that this commands not working yet.

​it *is* working

Hi Axel,

I just tried according to your suggestion and it is working now. Thanks !

Best
Ming

this was a bug - fixed it

will be in next patch, thanks

Steve