Problem With Edip

Hello,

I have run across an issue where running LAMMPS with edip potential that gives incorrect energies as a run progresses. The value of potential energy and total energy increase much at high temperatures.This simulation was run at 900K. But when I use the same command with sw potential that gives correct energies as runing LAMMPS.

   Simulation cell size: 5 x 5 x 5 with periodic boundary conditions
velocity	all create 900.0  574213  sum yes dist gaussian
Ensamble: NPT

Note:The system's potential energy and total energy cannot be controled with edip potential as temperature above 1000K, but when I use same ensamble or command with sw potential,the program run well, and potential energy didn't change much。Normally,the value of potential energy always keep in negative. 
here is a part of my output file

Step Temp PotEng TotEng Press Volume Lx
0 900 -4649.9538 -4533.736 6199.7675 20018.405 27.1525
500 952.26437 -4450.6787 -4327.7119 -508.15265 19748.969 26.787043
1000 993.3353 -3224.2532 -3095.9829 -28541.332 18175.676 24.653066
1500 900.34635 -583.46539 -467.20287 -96161.113 15430.376 20.929404
2000 875.05799 1917.8296 2030.8266 -279492.2 13506.425 18.319801
2500 902.1558 2870.971 2987.4672 -313867.51 12994.346 17.62523
3000 887.58273 3554.8086 3669.423 -388265.11 12649.567 17.157579
3500 878.53804 3754.7113 3868.1577 -417915.92 12551.463 17.024513
4000 904.70039 3928.8371 4045.6618 -387268.62 12488.391 16.938964
4500 925.80229 4047.9514 4167.5011 -383299.26 12435.371 16.867049

Hello,

I have run across an issue where running LAMMPS with edip potential that
gives incorrect energies as a run progresses. The value of potential energy
and total energy increase much at high temperatures.This simulation was run
at 900K. But when I use the same command with sw potential that gives
correct energies as runing LAMMPS.

   Simulation cell size: 5 x 5 x 5 with periodic boundary conditions

velocity all create 900.0 574213 sum yes dist gaussian

Ensamble: NPT

Note:The system's potential energy and total energy cannot be controled with
edip potential as temperature above 1000K, but when I use same ensamble or
command with sw potential,the program run well, and potential energy didn't
change much。Normally,the value of potential energy always keep in negative.

here is a part of my output file

Step Temp PotEng TotEng Press Volume Lx
0 900 -4649.9538 -4533.736 6199.7675 20018.405
27.1525
500 952.26437 -4450.6787 -4327.7119 -508.15265 19748.969
26.787043
1000 993.3353 -3224.2532 -3095.9829 -28541.332 18175.676
24.653066
1500 900.34635 -583.46539 -467.20287 -96161.113 15430.376
20.929404
2000 875.05799 1917.8296 2030.8266 -279492.2 13506.425
18.319801
2500 902.1558 2870.971 2987.4672 -313867.51 12994.346
17.62523
3000 887.58273 3554.8086 3669.423 -388265.11 12649.567
17.157579
3500 878.53804 3754.7113 3868.1577 -417915.92 12551.463
17.024513
4000 904.70039 3928.8371 4045.6618 -387268.62 12488.391
16.938964
4500 925.80229 4047.9514 4167.5011 -383299.26 12435.371
16.867049

please let me know if there is anything else I can do to help track down and
resolve this bug.

i don't think it is a bug. your symptoms look more
like you have too large a time step for your model.

axel.