Problem with log command : Binary log file instead of ASCII

Hello dear,
I installed and built the latest version of LAMMPS (11 Aug 2017) and generated the executable lmp_gpu. When I ran of my older scripts with this executable to check, I realized that I cannot open the output log file with Text Editor since it is written in binary format. What can be the reason for this change ? (my older executable was lmp_ubuntu_parallel). Do I miss something when building the new version ?
Thank you

Huh? You mean the log file itself (log.lammps)? That should not be binary (as far as I know). If you mean a dump or restart file, that’s a different story.

Hello dear,
I installed and built the latest version of LAMMPS (11 Aug 2017) and
generated the executable lmp_gpu. When I ran of my older scripts with this
executable to check, I realized that I cannot open the output log file with
Text Editor since it is written in binary format. What can be the reason
for this change ? (my older executable was lmp_ubuntu_parallel). Do I miss
something when building the new version ?

​there has been no change in the log file format. log file output is
more-or-less the same as what​ it used to be and what is printed to the
screen (depending on the value of the echo flag).

the only ways i know to turn this into binary is file system corruption.
that can be due to bad RAM, a bug in the file system driver, a defective
hard drive, a broken disk controller or writing to the same file from
multiple processes when the log file is hosted on a networked file system.

​axel.​