problem with pair_style adp

Dear Lammps users,

I want to use “adp” pair_style in my simulation, but Lammps gives me the error “invalid pair_style”. I have already made Lammps including “manybody” package. Is there anything I have missed to do?

Thanks,
Iman.

Dear Lammps users,
I want to use "adp" pair_style in my simulation, but Lammps gives me the
error "invalid pair_style". I have already made Lammps including "manybody"
package. Is there anything I have missed to do?

you have forgotten to mention which version of lammps you have.

axel.

The version is Dec 21 2010.

Thanks.

The version is Dec 21 2010.

there you go. your code is outdated and doesn't contain this feature.
you can't use what isn't there.

it is in the svn/git mirror only since two weeks ago.

[[email protected] MANYBODY]$ git log pair_adp.cpp
commit aedbb28b6c34018f63561b2002030f5e5e69dfe1
Author: sjplimp <[email protected]>