Problem with parallelization


I am trying to use parallelization in lammps to simulate polymers. I am using a cluster with the command “bsub.” my input to the cluster looks like so:

bsub -q day -n 32 -o out.%J -e err.%J -a openmpi mpirun “./lmp_linux<in.pompom12424.1.000000”

where -q day designates the queue used and -n 32 designates how many cores I want the program to run on. I tried both openmpi as well as mvapich, however none of them works. Even though I tell the cluster I want to simulate the program on more than one core, in the out file, it tells me “1 by 1 by 1 processor grid”, and all of the cores, except for one, run for around 1 second, and then they say “done”, and the single remaining core continues to execute the program, so it is as if my program is running serially. Is there some library that I am missing?

When I was making the lammps executable there was one single folder in lammps that I changed, because I did not need the FFT library, and otherwise LAMMPS did not compile properly. That folder is attached. It is makefile.linux in the src/MAKE/makefile.linux.

Thank you

Makefile.linux (2.6 KB)


  I tried to this issue before.
  My solution is to check the bsub manual and try to write scripts instead of command to submit jobs.

Best wishes,

在 Jun 12, 2011,8:06 PM, Alexandru Bacanu 写道:

I'm not familiar with bsub, but this does not sound like a LAMMPS
issue. Rather it is a bsub or MPI issue.