problem with windows version

Dear Lammps users and Developers

I have installed the 64 bit Pre-compiled Windows installers version of Lammps and Mpich2 in my windows7, 64 bit as described in "http://git.icms.temple.edu/rpm/windows.html".
I tried to run the simulation with “mpiexec -np 4 lmp_mpi < run.in” command, but almost when I entered to run don’t anything occurred. but some times when abort the job and try to do it more, it start to run correctly. (it is really random) I tried this on 2 other PC with windows7, but the problem is exist. when I used lmp_serial everything is OK.

please help me.

Thanks

Hadi

Dear Lammps users and Developers
I have installed the 64 bit Pre-compiled Windows installers version of
Lammps and Mpich2 in my windows7, 64 bit as described in
"http://git.icms.temple.edu/rpm/windows.html&quot;\.
I tried to run the simulation with "mpiexec -np 4 lmp_mpi < run.in" command,
but almost when I entered to run don't anything occurred. but some times
when abort the job and try to do it more, it start to run correctly. (it is
really random) I tried this on 2 other PC with windows7, but the problem is
exist. when I used lmp_serial everything is OK.

input redirection is broken with many MPI implementations (in fact, i
am always surprised that people expect it to work, because it is far
from trivial). use the -in flag.

axel.

I’m guessing that’s a Windows issue.
I’ve never seen that problem on a Linux box

or supercomputer.

Steve

Happens on some linux boxes, too with some more obscure mpi implementations. multiplexing stdin across many processes properly is far from trivial. And since lammps supports the -in flag there is no need to go this way.

Axel.

Thanks Axel, I use -in flag and the problem solved.
I have a problem when using dump cfg in windows. I use the following command.
"dump cfgrelax all cfg ${relaxcfgstep} relax.*.cfg id type xs ys zs vx vy vz c_stress[3] c_stress[5] c_stress[6] c_enperatom c_keperatom

dump_modify cfgrelax element A B"

I don’t have any problem in linux but when I used in windows7 I have the following error.
“ERROR: Dump cfg arguments must start with ‘mass type xs ys zs’ or ‘mass type xsu ysu zsu’”
I don’t know why this happened but I used mass instead of id and then the job aborted. please guide me where is my problem.
hanks
Hadi

Dumg cfg command has recently been changed. Just change id to mass.

Ray

Dear Ray

Thanks for your reply. as I wrote in last Email, I have changed id to mass, but the simulation aborted and

give me the following error.

Thanks in advance

Hadi

“Error while decoding stream #0:0: Invalid data found when processing input
pipe:: Input/output error”

This is very strange. You are not by any chance also trying to use dump movie?

It would also be helpful to know which version of lammps exactly you are using.

It would probably be best to post a small input so that somebody van check it.

I am currently travelling halfway around the globe (and then some), so it may take a few days until I could check this out in myself.

Axel.

the lammps version is:
(22 Nov 2013-ICMS)

I tried by adding "dump 2 all cfg 10 relax.*.cfg mass type xs ys zs vx
vy vz" to in.RDX example in example/reax/RDX folder and test it. But
the job aborted again. I am sorry, because I didn't attached the
in.RDX script, because I am sendin this email by mobile.
Thanks in advance
Hadi

the lammps version is:
(22 Nov 2013-ICMS)

I tried by adding "dump 2 all cfg 10 relax.*.cfg mass type xs ys zs vx
vy vz" to in.RDX example in example/reax/RDX folder and test it. But
the job aborted again. I am sorry, because I didn't attached the
in.RDX script, because I am sendin this email by mobile.

just tested this and cannot reproduce any issues.

axel.

I tried the new version of lammps for windows and the problem solved. The version of ‘22 Nov’ have problem to dump cfg file. (I don’t know why)
Thanks
Hadi