Problems in using fix spring/self during restart across nodes

Dear LAMMPS users,

I met a very strange problem in using fix spring/self during restart across nodes.

I first ran my simulation with the 4 nodes (64 cores), then I restarted it, it just crashed with no output. However, while nothing changed, I just used one node (16 cores), it worked fine. I’ve also removed the fix spring/self section and used 4 nodes (64 cores), it also worked well.

So to my understanding, it seems this is caused by some parallel problems with fix spring/self. Could anybody help me on this? Thanks a lot.


First check that the problem is reproducible *with the latest version
of LAMMPS*. If yes, then see if you can reproduce the behavior in a
*small and simple* example (include initial and restart scripts). If
yes, post it here and we will take a look. If either of the "if yes"
tests fail, then you have effectively solved it for yourself and you
can skip the remaining steps. You just need to use the solution in
your original calculation.