Problems modelling tethered particle with angular momentum

Hi all,

I’m trying to model a tethered spherical nanoparticle (NP) in which the tether comprises a bead-spring polymer built from point masses and the NP is a rigid body. Interactions in the tether include pair, bond, and angle potentials to respectively incorporate excluded volume, tether continuity, and persistence length into the model. The tether is bound to the NP with these same interactions.

Previously I used a point mass for the NP, which worked fine, but now I want to include angular momentum/velocity as imparted by the implicit solvent, implemented via e.g. a Langevin fix; hence the NP needs to be of finite-size.

I’m trying to use ‘atom_style hybrid angle sphere’, but I can’t seem to make a data file with the correct atom format.
If I correctly understand the docs, the format in the ‘Atoms’ section for ‘atom_style hybrid angle sphere’ in this case should be:

atom-ID atom-type x y z molecule-ID diameter density

However, I keep getting the error “Incorrect atom format in data file”. I also considered the (minor) possibility that something weird is happening with the encoding or linebreaks since I manually edit the file in notepad++, but this has not been a problem previously. I tried searching the mailing list for this problem specifically, but (perhaps due to my google-fu limitations) did not find a sufficiently relevant post. The data- and input-files are attached.

I also tried fix/rigid/nve, defining the body using particles on the vertices of an icosahedron and a central particle which interacts with the tether, but I don’t know how (i.e. haven’t thought/looked hard enough yet) to impart uniform density using that command, so I decided to try atom_style hybrid angle sphere first.

Lastly I looked at the body style, but understood that it should be used for more complex shapes than a simple sphere with uniform density.

Could anyone suggest a solution for the problem with the data file, or perhaps a better approach to this problem altogether?
Help is much appreciated.

Kind regards,

Joost Bergen
Student at Eindhoven University of Technology, Netherlands
Department of Biomedical Engineering and department of Physics

TEST3045_df.df (1.53 KB) (3.66 KB)

you may want to update to a more recent LAMMPS version. I get a different, and more specific error message:

$ ./lmp -in
LAMMPS (18 Feb 2020)
Reading data file …
orthogonal box = (-3.7308e-08 -3.7308e-08 0) to (3.7308e-08 3.7308e-08 6.9616e-08)
1 by 1 by 1 MPI processor grid
WARNING: Atom style in data file differs from currently defined atom style (src/read_data.cpp:514)
reading atoms …
12 atoms
ERROR: Duplicate atom IDs exist (src/atom.cpp:671)
Last command: read_data TEST3045_df.df

Which is correct as your last three atoms have the same atom id 11.


Hello dr. Kohlmeyer,

Thank you for your suggestion; updating indeed LAMMPS resolved the issue. The data files and (input file) I provided contained mistakes, although they were probably not related to the error I got before, as with valid data files I previously got the “Incorrect atom format in data file” message. Nevertheless, proper data/input files using a new LAMMPS version worked indeed.

In case anyone else experiences something similar it might be relevant to know which version I used and which I’m using now:
I updated from LAMMPS x64 7Aug2019 to LAMMPS x64 24Jan2020 which resolved the issue.

Kind regards,