Problems with restart2data

Hi folks,

I’m trying to use the restart2data tool and received the following error:

[jzimmer]$ ~/lammps-atc/tools/restart2data four_bubble_setup.rst four_bubble_setup.data
Reading restart file …
WARNING Restart file version does not match restart2data version
restart2data version = 6 Feb 2012
ERROR: Invalid flag in header section of restart file 128

I checked and the LAMMPS version I’m using is marked as 17 Feb 2012, which should be compatible with this version of restart2data, no? Any ideas?

Thanks,

Jon Z.

Axel - any ideas on this - I think you were the last person
to edit restart2data.cpp. The 128 flag looks to
big to be keyword in the enum{} header, so I think
the format must be mis-matched ... (reading the wrong
field).

Steve

Axel - any ideas on this - I think you were the last person

not yet. i've been catching up on pending
issues and this is on the list.

to edit restart2data.cpp. The 128 flag looks to
big to be keyword in the enum{} header, so I think
the format must be mis-matched ... (reading the wrong
field).

yeah, something like that.
for certain i was the last to
mix up things in restart2data,
so i should sort it out as well.

jon, can you send me a simple input
that reproduces this, in case i cannot
reproduce it with the tests that i have?

thanks,
   axel.