Required Hybrid style for Pair_coeff


I am using the TraPPE parameter for CO2. But when I run the input script on LAMMPS, it shows " Expected floating point parameter in input script or data file (…/pair_lj_cut.cpp:458)". So, I used hybrid/overlay command in the pair_style command. But then it shows “Pair coeff for hybrid has invalid style”. So,what hybrid command can I use in this case? I attached the input file and data file.

Please help

You get errors, when you input has incorrect syntax. Switching to a hybrid pair style does not correct your errors. For a simple model like TraPPE based CO2 you should not need any hybrid style anywhere.
To know what is the correct syntax you have to study the LAMMPS manual and the corresponding pages for the commands and styles you are using. If you change your input to follow the documented syntax correctly, LAMMPS will not abort with error messages like you have seen (of course that does not guarantee that you’ll be modeling the correct physics, since that cannot be as easily checked for as the correct syntax. :wink:).

But for small molecule like CO2, O2, and N2, I can not see any specific pair_style for TraPPE parameter in LAMMPS documentation. Is there any way or method how can I understand it? It will be better if you give some example or guideline. Actually, I am new in LAMMPS. Please help!

You have to look up which potential functions TraPPE uses for its model and match it with the available styles in LAMMPS.

How this works in general and teaching you MD simulation basics is beyond the scope of the LAMMPS category. You should have training in these matters before starting with a simulation software. Consult with your adviser or experienced colleagues to give you a suitable introduction.