Restart2data Invalid Flag Error


when i run your input and make it write out restarts
(by inserting write_restart restart.init right before the run
statement) i can convert them back to data files without
a problem.

this is with version 4 dec 2011 of lammps.

but i do get the same error on the binary restart that
you bundled with the zip file. is the restart created
on the same machine that you compiled restart2data on?



Glad to hear that you've found a method that works. To answer your question, yes, I'm using the same cluster to create the restart file and compile restart2data on. Worth noting, I ran the same simulation (for one timestep) on my laptop earlier today and was able to convert to a data file with no problem. I was using an older version of lammps though (13 Jul 2011, restart2data v. 25 Jun 2011). However, if I copy the restart file created on the cluster (v. 12/1/2011) to my laptop (v. 7/13/2011), I receive the same error as if I tried converting the file on the cluster. Which concurs with what you said about restart files varying slightly between versions.


Quoting Axel Kohlmeyer <[email protected]>: