run with nan

Hi:

I am modeling molten salts with simple ions systems, such as halides, alkali metal ions,alkali earth metal ions. 
I build up the molten NaCl model with some commands as in the input script, 
and I want to simulate it with born/coul/long pair potential.

Input script:

units        metal
dimension 3
boundary p p p
atom_style    charge

region        regbox block 0 18.8 0 18.8 0 18.8 units box
create_box    2 regbox
create_atoms    1 random 106 16 regbox units box
create_atoms    2 random 106 16 regbox units box
mass        1 23.0
mass     2 35.5
set type 1 charge 1.0
set type 2 charge -1.0

pair_style born/coul/long 10.0 8.0
pair_coeff 1 1 0.2640625 0.317 2.340 1.05 0.5
pair_coeff 1 2 0.21125 0.317 2.755 7 8.6875
pair_coeff 2 2 0.1584375 0.317 3.170 72.5 145.625
kspace_style ewald 1.0e-5

neighbor    0.1 bin
neigh_modify    every 5 delay 0 check no
timestep 0.005
minimize 1.0e-4 1.0e-4 100 1000

compute          1 all msd         
 
velocity    all create 1073.0 87287 dist gaussian
run              0
 
thermo           5000
thermo_style     custom step etotal temp c_1[4]  
 
thermo_modify    flush yes
dump             1 all custom 100000 dump.* id type x y z
dump             2 all cfg 100000 a*.cfg id type xs ys zs
dump_modify    1 element Na1 Cl2
 
fix              1 all npt temp 1073 1073 4 aniso 0 0 4
run              500000
 
unfix            1
fix              1 all nvt temp 1073 1073 0.1 drag 0.2
run              500000

The atoms in the box are random, so I minimize the system before running it to avoid atoms overlapping.
But after running the input script, I met 'nan' problems at minimize step as below, and the simulation stopped at 
this state for several days, the screen didn't print anything again. 

LAMMPS (17 Oct 2012)
Created orthogonal box = (0 0 0) to (18.8 18.8 18.8)
  1 by 1 by 1 MPI processor grid
Created 106 atoms
Created 106 atoms
Setting atom values ...
  106 settings made for charge
Setting atom values ...
  106 settings made for charge
WARNING: Resetting reneighboring criteria during minimization (min.cpp:173)
Ewald initialization ...
  G vector (1/distance) = 0.384136
  estimated absolute RMS force accuracy = 0.000144311
  estimated relative force accuracy = 1.00219e-05
  KSpace vectors: actual max1d max3d = 1054 8 2456
Setting up minimization ...
Memory usage per processor = 11.0297 Mbytes
Step Temp E_pair E_mol TotEng Press
       0            0          nan            0          nan          nan

I asked for help in some schoolar forums, someone replied that he can obtain results as below:

Setting up minimization ...
 Memory usage per processor = 8.75168 Mbytes
 Step Temp E_pair E_mol TotEng Press
        0            0     3283.825            0     3283.825    1841942.5
        1            0    2201.9244            0    2201.9244    1191267.3
        2            0 1.1420382e+28            0 1.1420382e+28 7.3432144e+30
 Loop time of 0.0345552 on 1 procs for 2 steps with 212 atoms

 Minimization stats:
   Stopping criterion = linesearch alpha is zero
   Energy initial, next-to-last, final =
          3283.82497763      2201.92444207  1.14203823754e+28
   Force two-norm initial, final = 20954.6 2.00103e+32
   Force max component initial, final = 11759.7 1.14428e+32
   Final line search alpha, max atom move = 2.10676e-16 2.41072e+16
   Iterations, force evaluations = 2 40

I don't know why my machine can't do the computatiom and the reasons of "nan". Also, I am not sure whether the way of 
building the model is correct.

Would highly appreciate if any advise!

Thanks & Best Regards!

Wang jia
Postgraduate 
East China University of Science and Technology
Shanghai, China
Tel: 18616024679