running lamps in parallel

Hi lammps users,

I’m trying to run lammps via the command : “mpirun -n 40 lmp_openmpi < in.test_file” . Lammps seems to run, but then it remains frozen i.e on the screen only appears the current lammps version (nothing else). If i run “mpirun -n 40 lmp_openmpi -in in.test_file” , then lammps runs succesfully i.e the output is printed on the screen. Can someone explain what is the difference between using “<” and “-in”

Oscar Guerrero

The '<' redirect the input to the program that you are running from
the file in.test_file, it is like typing the input to the program, but
the file is 'typing' for you.

The -in option of lammps uses C++ functions to read the input file.

The only problem that can arise (as far as I know) is if you are using
some kind of loop in the lammps script that involves the 'jump'
command to the same script, for example "jump SELF loop", then it is
advisable to use -in option.

It would help a lot if you could put what the input file is.


You should get some output to the screen, even if the file has a loop.
This sounds like an MPI problem, not a LAMMPS issue.