Segmentation fault with fix ave/time and rerun

Hello everyone,

I'm trying to simulate a box of TIP4P water, and to compute the RDF for
O-O pairs. So I'm using the compute rdf, fix ave/time and rerun commands.
And I'm getting a segmentation fault. My input script is at the end of
this message.

This error occurs only with the rerun command : using a normal run command
produce a good output.

The files referenced in my script were produced with "dump trj all xyz 10
water.trj.xyz" for water.trj.xyz; and "write_restart water-*.rst" for the
water-*.rst file.

I had a look at the documentation and this mailing list archives, but did
not found anything about this.

My configuration is: CentOS 6.5, with linux 2.6.32-431.5.1, LAMMPS (26 Feb
2014-ICMS) installed from the pre-built RPM.

Do you have any idea about the origin of this segfault ?
Thanks a lot for the time you may take to help.
Regards,

I think you want fix ave/time 10 1 10, since your
dump file only has snapshots every 10 timesteps.

That could be why it is crashing (should just give an error),
but I’d need a small dump file and restart file to test it.

Steve

Hi, thank you for your awnser.

I have tried with these parameters, but I still get a "Segmentation fault
(core dumped)" error. I'll try to prepare a minimal dump and restart file
for reproducing this issue.

Hi, here is a small dump file to reproduce this problem.

If you just want to reproduce the segmentation fault, juts download “rdf.in” and “water.xyz” files. Running lammps (with something like “lmp_g++ -in rdf.in”) should give you the error. The problem is definitively with the rerun command: if I remove the stop value, it does works ! (see the rdf.in script) If you also want recreate the dump file, get “water.lmp” and run the “run.in” script. This will output “water.xyz”. Thanks again for your help, Guillaume Fraux

compose-unknown-contact.jpg

Hi everyone,

My last message was sent in HTML, making it impossible to read.
I'm sorry about this, here is the same message in text form.

I hope you may find where does this issue come from.

Regards,
Guillaume.

LAMMPS should flag an error when you try to read
a snapshot via the rerun command with a timestep

larger than the “stop” value you specified. I added
a check for that.

Note that I don’t know why you are using a “stop” value
in the command. I suggest you read the doc page for

rerun carefully. Stop and last have different meanings

and I suspect you mean to use last. Stop is only
rarely useful.

Also note that timesteps from an xyz dump file
are not recognized b/c there is no standard format
for them. See the read_dump doc page for a note
about that. So you need to be careful how you define
your fix ave/time command to average the RDF on

the snapshots you want.

Steve

Thank you for fixing this !

Effectively, I didn't get the difference between stop and last.

In the mean time, I changed my trajectory format, and wrote my own rdf
calculation, so I can choose carefully the snapshots I want.

This should be useful for other newcomers to LAMMPS.

Regards,
Guillaume