Segmentation fault with Python package

Dear LAMMPS Users,

Yesterday I tried to install lammps on a cluster, the installation was successful

but when I tested one of the examples (shear) i encountered an error (Segmentation fault)

It seems that the Python package caused the problem since when I removed it the error gone.

I tried both versions of python (one that is loaded from HPC (2.7.6) and the other is from anaconda2 (2.7.13))

in case of anaconda use, I use the Makefile in python package was modified as below

python_SYSINC = -I/home/vnt981/anaconda2/include/python2.7

python_SYSLIB = -lpython2.7 -lnsl -ldl -lreadline -ltermcap -lpthread -lutil -lm
python_SYSPATH = -L/home/vnt981/anaconda2/lib

The attached files below include the output as well as the log of my test.
Any ideals or solutions about my problem are welcome.

Thank you so much

error.log (544 Bytes)

in.shear (1.5 KB)

log.lammps (7.9 KB)

out.shear (6.71 KB)

before writing a e-mail like this, please read the following pages very carefully:

http://lammps.sandia.gov/bug.html

and:

http://lammps.sandia.gov/guidelines.html

axel.

You don’t say what version of LAMMPS you are using, but

this was possibly fixed with the 13Apr17 patch.

Steve