Snap error

Hi there,

I used to run LAMMPS calculations on my own computer with no problem. However, now that I require more computational power, I am starting to run the calculations in a computing cluster. I launched some calculations with a eam intertatomic potential without any problem, even some NEBs. However, now I am running calc with a machine learning (ML) interatomic potential and I have the following error:

LAMMPS (3 Mar 2020)
OMP_NUM_THREADS environment is not set. Defaulting to 1 thread. (src/comm.cpp:94)
  using 1 OpenMP thread(s) per MPI task
Reading data file ...
  orthogonal box = (0 0 0) to (31.0987 10.9881 31.72)
  2 by 1 by 4 MPI processor grid
  reading atoms ...
  457 atoms
  read_data CPU = 0.0321804 secs
SNAP Element = W, Radius 0.5, Weight 1
SNAP keyword rcutfac 4.7
SNAP keyword twojmax 8
SNAP keyword rfac0 0.99363
SNAP keyword rmin0 0.0
SNAP keyword bzeroflag 1
SNAP keyword quadraticflag 0
SNAP keyword bnormflag 0
ERROR: Incorrect SNAP parameter file (src/SNAP/pair_snap.cpp:705)
Last command: pair_coeff * * W_LML.snapcoeff W_LML.snapparam W

If I run exactly the same calc on my computer, it finishes with no problems. Any suggestion?


Did you check if the corresponding package is installed on the cluster that you are using?
check with:
./lmp -h | less


Are you using exactly the same version of LAMMPS on both computers?

Thank you very much, I didnt know this command. The module SNAP is load, but not ML-SNAP. I think that this is the problem.


Can you provide first three lines of output after running lmp -h on both computers?

Well, you are right. The version I’ve downloaded on my computer is lammps-29Sep2021, while the cluster is lammps-03Mar2020. Anyway, I think the problem is that the cluster version of lammps does not have compiled the ML-SNAP module.

That is not correct. The package was renamed from SNAP to ML-SNAP between those versions. You need a newer version of LAMMPS on your cluster.

Thanks for your comment, Axel. I’ll let cluster support know too.

I suggest you update to the latest stable release 23 June 2022 for more features, bugfixes, and performance enhancements.

The package was obviously installed, or else there would not have been an error message from pair style snap. If you use a style from a missing package, LAMMPS will print a corresponding message.

Thanks for tthe correction!

Warm regards,

Is SNAP library is different from ML-SNAP? I had similar error in my simulation. SNAP module is already there in my LAMMPS. I tried to find ML-SNAP, but it is not there. Please help

Yes, SNAP was just renamed to ML-SNAP. We would all highly suggest updating to a newer version of LAMMPS, don’t really want to debug an old version of LAMMPS.

I am using 29 Oct 2020 version of LAMMPS. Upgrade required in this case?

My issue resolved with 22 Dec 2022 version of LAMMPS. But now I have new error ‘unknown parameter diagonal style in snap parameter file’.
What is the meaning of this error?

The meaning is exactly what the error message says. Your SNAP parameter file has a keyword that is not known. That likely means you are using the wrong file in the pair_coeff command.

That keyword (diagonalstyle) was removed from SNAP, just needs to be deleted out of the file. See note here: pair_style snap command — LAMMPS documentation

“The previously used diagonalstyle keyword was removed in 2019, since all known SNAP potentials use the default value of 3.”

Thanks for the information.